<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# website: http://ogp.me/ns/website#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="http://ndsuspectrum.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v16.0.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Travis Scott&#039;s horrific concert could have been prevented - the Spectrum</title>
	<link rel="canonical" href="http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Travis Scott&#039;s horrific concert could have been prevented - the Spectrum" />
	<meta property="og:description" content="Concert-goers should never have to experience something like the Astroworld tragedy A concert is made for making you feel alive. Travis Scott’s Astroworld Festival incident &quot;Travis Scott&#8217;s horrific concert could have been prevented&quot;" />
	<meta property="og:url" content="http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/" />
	<meta property="og:site_name" content="the Spectrum" />
	<meta property="article:publisher" content="https://www.facebook.com/ndsuspectrum" />
	<meta property="article:published_time" content="2021-11-16T14:00:00+00:00" />
	<meta property="article:modified_time" content="2021-11-16T05:46:54+00:00" />
	<meta property="og:image" content="http://ndsuspectrum.com/wp-content/uploads/2021/11/unnamed-6.png" />
	<meta property="og:image:width" content="512" />
	<meta property="og:image:height" content="342" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@NDSUSpectrum" />
	<meta name="twitter:site" content="@NDSUSpectrum" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Kilee Blume">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="4 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://ndsuspectrum.com/#organization","name":"The Spectrum","url":"http://ndsuspectrum.com/","sameAs":["https://www.facebook.com/ndsuspectrum","https://instagram.com/thespectrumndsu/","https://twitter.com/NDSUSpectrum"],"logo":{"@type":"ImageObject","@id":"http://ndsuspectrum.com/#logo","inLanguage":"en-US","url":"http://ndsuspectrum.com/wp-content/uploads/2014/02/new_web_logo.jpg","width":600,"height":98,"caption":"The Spectrum"},"image":{"@id":"http://ndsuspectrum.com/#logo"}},{"@type":"WebSite","@id":"http://ndsuspectrum.com/#website","url":"http://ndsuspectrum.com/","name":"the Spectrum","description":"For the Land and its People","publisher":{"@id":"http://ndsuspectrum.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"http://ndsuspectrum.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/#primaryimage","inLanguage":"en-US","url":"http://ndsuspectrum.com/wp-content/uploads/2021/11/unnamed-6.png","width":512,"height":342,"caption":"Travis Scott\u2019s Astroworld performance in Houston ends in horrific accident."},{"@type":"WebPage","@id":"http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/#webpage","url":"http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/","name":"Travis Scott's horrific concert could have been prevented - the Spectrum","isPartOf":{"@id":"http://ndsuspectrum.com/#website"},"primaryImageOfPage":{"@id":"http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/#primaryimage"},"datePublished":"2021-11-16T14:00:00+00:00","dateModified":"2021-11-16T05:46:54+00:00","breadcrumb":{"@id":"http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/"]}]},{"@type":"BreadcrumbList","@id":"http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"http://ndsuspectrum.com/","url":"http://ndsuspectrum.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/","url":"http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/","name":"Travis Scott&#8217;s horrific concert could have been prevented"}}]},{"@type":"Article","@id":"http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/#article","isPartOf":{"@id":"http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/#webpage"},"author":{"@id":"http://ndsuspectrum.com/#/schema/person/1bed2ddd58b34e9a9b89d5996559e330"},"headline":"Travis Scott&#8217;s horrific concert could have been prevented","datePublished":"2021-11-16T14:00:00+00:00","dateModified":"2021-11-16T05:46:54+00:00","mainEntityOfPage":{"@id":"http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/#webpage"},"commentCount":0,"publisher":{"@id":"http://ndsuspectrum.com/#organization"},"image":{"@id":"http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/#primaryimage"},"keywords":"Astroworld,music festival,Travis Scott","articleSection":"Opinion","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/#respond"]}]},{"@type":"Person","@id":"http://ndsuspectrum.com/#/schema/person/1bed2ddd58b34e9a9b89d5996559e330","name":"Kilee Blume","image":{"@type":"ImageObject","@id":"http://ndsuspectrum.com/#personlogo","inLanguage":"en-US","url":"http://2.gravatar.com/avatar/2595f4b007c5a1f6faa1ea59e08c0cb0?s=96&d=mm&r=g","caption":"Kilee Blume"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="the Spectrum &raquo; Feed" href="http://ndsuspectrum.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="the Spectrum &raquo; Comments Feed" href="http://ndsuspectrum.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="the Spectrum &raquo; Travis Scott&#8217;s horrific concert could have been prevented Comments Feed" href="http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v7.16.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-49923412-1"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.16.2';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-49923412-1';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-49923412-1', {
						forceSSL:true,link_attribution:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/ndsuspectrum.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://ndsuspectrum.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='ccf-jquery-ui-css'  href='//ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='ccf-form-css'  href='http://ndsuspectrum.com/wp-content/plugins/custom-contact-forms/assets/build/css/form.min.css?ver=7.8.5' type='text/css' media='all' />
<link rel='stylesheet' id='rit-core-front-css-css'  href='http://ndsuspectrum.com/wp-content/plugins/rit-core/assets/css/rit-core-front.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='rit-blog-css-css'  href='http://ndsuspectrum.com/wp-content/plugins/rit-core/assets/css/blog-style.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='rit-masonry-css-css'  href='http://ndsuspectrum.com/wp-content/plugins/rit-core/assets/css/rit-masonry.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='rit-news-css-css'  href='http://ndsuspectrum.com/wp-content/plugins/rit-core/assets/css/rit-news.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='rit-social-counter-frontend-css-css'  href='http://ndsuspectrum.com/wp-content/plugins/rit-core/inc/social-counter/css/rit-social-counter-frontend.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='yop-public-css'  href='http://ndsuspectrum.com/wp-content/plugins/yop-poll/public/assets/css/yop-poll-public-6.2.6.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='cocktail-styles-css'  href='http://ndsuspectrum.com/wp-content/plugins/cocktail-plus/inc/css/cocktail-styles.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='cocktail-google-fonts-css'  href='//fonts.googleapis.com/css?family=Lora%7CNoto+Sans%3A300%2C400%2C400i%2C500%2C600%2C700&#038;ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='monsterinsights-popular-posts-style-css'  href='http://ndsuspectrum.com/wp-content/plugins/google-analytics-for-wordpress/assets/css/frontend.min.css?ver=7.16.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://ndsuspectrum.com/wp-includes/css/dashicons.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='cocktail-style-css'  href='http://ndsuspectrum.com/wp-content/themes/cocktail/style.css?ver=5.8.2' type='text/css' media='all' />
<style id='cocktail-style-inline-css' type='text/css'>
/* Header Image With background Text color */
		.header-image-title {
			background-color: rgba(0,0,0,0.3);
			padding: 8px 26px;
			width: auto;
		}
.header-image-title {
				left: 50%;
				top: 50%;
				transform: translate(-50%, -50%);
				right: auto;
				bottom: auto;
				text-align: center;
			}
</style>
<link rel='stylesheet' id='font-awesome-css'  href='http://ndsuspectrum.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?ver=4.11.1' type='text/css' media='all' />
<link rel='stylesheet' id='cocktail-responsive-css'  href='http://ndsuspectrum.com/wp-content/themes/cocktail/css/responsive.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='yellow-pencil-animate-css'  href='http://ndsuspectrum.com/wp-content/plugins/waspthemes-yellow-pencil/library/css/animate.css?ver=5.8.2' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"http:\/\/ndsuspectrum.com","hash_tracking":"false","ua":"UA-49923412-1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=7.16.2' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.12.1' id='jquery-ui-datepicker-js'></script>
<script type='text/javascript' id='jquery-ui-datepicker-js-after'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' id='ccf-form-js-extra'>
/* <![CDATA[ */
var ccfSettings = {"ajaxurl":"http:\/\/ndsuspectrum.com\/wp-admin\/admin-ajax.php","required":"This field is required.","date_required":"Date is required.","hour_required":"Hour is required.","minute_required":"Minute is required.","am-pm_required":"AM\/PM is required.","match":"Emails do not match.","email":"This is not a valid email address.","recaptcha":"Your reCAPTCHA response was incorrect.","recaptcha_theme":"light","phone":"This is not a valid phone number.","digits":"This phone number is not 10 digits","hour":"This is not a valid hour.","date":"This date is not valid.","minute":"This is not a valid minute.","fileExtension":"This is not an allowed file extension","fileSize":"This file is bigger than","unknown":"An unknown error occured.","website":"This is not a valid URL. URL's must start with http(s):\/\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/custom-contact-forms/assets/build/js/form.min.js?ver=7.8.5' id='ccf-form-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/rit-core/assets/js/rit-core-front.js?ver=2.0' id='rit-core-front-js-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/waspthemes-yellow-pencil/library/js/animation-events.js?ver=5.8.2' id='yellow-pencil-library-js'></script>
<script type='text/javascript' id='yop-public-js-extra'>
/* <![CDATA[ */
var objectL10n = {"yopPollParams":{"urlParams":{"ajax":"http:\/\/ndsuspectrum.com\/wp-admin\/admin-ajax.php","wpLogin":"http:\/\/ndsuspectrum.com\/wp-login.php?redirect_to=http%3A%2F%2Fndsuspectrum.com%2Fwp-admin%2Fadmin-ajax.php%3Faction%3Dyop_poll_record_wordpress_vote"},"apiParams":{"reCaptcha":{"siteKey":""},"reCaptchaV2Invisible":{"siteKey":""},"reCaptchaV3":{"siteKey":""}},"captchaParams":{"imgPath":"http:\/\/ndsuspectrum.com\/wp-content\/plugins\/yop-poll\/public\/assets\/img\/","url":"http:\/\/ndsuspectrum.com\/wp-content\/plugins\/yop-poll\/app.php","accessibilityAlt":"Sound icon","accessibilityTitle":"Accessibility option: listen to a question and answer it!","accessibilityDescription":"Type below the <strong>answer<\/strong> to what you hear. Numbers or words:","explanation":"Click or touch the <strong>ANSWER<\/strong>","refreshAlt":"Refresh\/reload icon","refreshTitle":"Refresh\/reload: get new images and accessibility option!"},"voteParams":{"invalidPoll":"Invalid Poll","noAnswersSelected":"No answer selected","minAnswersRequired":"At least {min_answers_allowed} answer(s) required","maxAnswersRequired":"A max of {max_answers_allowed} answer(s) accepted","noAnswerForOther":"No other answer entered","noValueForCustomField":"{custom_field_name} is required","consentNotChecked":"You must agree to our terms and conditions","noCaptchaSelected":"Captcha is required","thankYou":"Thank you for your vote"},"resultsParams":{"singleVote":"vote","multipleVotes":"votes","singleAnswer":"answer","multipleAnswers":"answers"}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/yop-poll/public/assets/js/yop-poll-public-6.2.6.min.js?ver=5.8.2' id='yop-public-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/themes/cocktail/js/html5.js?ver=3.7.3' id='html5-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="http://ndsuspectrum.com/wp-json/" /><link rel="alternate" type="application/json" href="http://ndsuspectrum.com/wp-json/wp/v2/posts/109005" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://ndsuspectrum.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://ndsuspectrum.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='http://ndsuspectrum.com/?p=109005' />
<link rel="alternate" type="application/json+oembed" href="http://ndsuspectrum.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fndsuspectrum.com%2Ftravis-scotts-horrific-concert-could-have-been-prevented%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://ndsuspectrum.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fndsuspectrum.com%2Ftravis-scotts-horrific-concert-could-have-been-prevented%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.17 to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:1px 1px 1px 1px;width:100%; max-width:468px; height:100%; max-height:60px; float:right; clear:right; }
	.g-2 { margin:1px 1px 1px 1px;width:100%; max-width:350px; height:100%; max-height:250px; }
	.g-3 { margin:1px 1px 1px 1px; }
	.g-4 { margin:1px 1px 1px 1px;width:100%; max-width:300px; height:100%; max-height:450px; }
	.g-5 { margin:1px 1px 1px 1px;width:100%; max-width:250px; height:100%; max-height:300px; }
	.g-6 { margin:1px 0px 0px 0px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->



<!-- Open Graph data is managed by Alex MacArthur's Complete Open Graph plugin. (v3.4.5) -->
<!-- https://wordpress.org/plugins/complete-open-graph/ -->
<meta property='og:site_name' content='the Spectrum' />
<meta property='og:url' content='http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/' />
<meta property='og:locale' content='en_US' />
<meta property='og:description' content='Concert-goers should never have to experience something like the Astroworld tragedyA concert is made for making you feel alive. Travis Scott&rsquo;s Astroworld Festival incident should not have happened. Travis Scott and his team should have stopped the show. Someone should have told him, &quot;Hey, peop' />
<meta property='og:title' content='Travis Scott&#8217;s horrific concert could have been prevented' />
<meta property='og:type' content='article' />
<meta property='og:image' content='http://ndsuspectrum.com/wp-content/uploads/2021/11/unnamed-6.png' />
<meta property='og:image:width' content='512' />
<meta property='og:image:height' content='342' />
<meta name='twitter:card' content='summary' />
<meta name='twitter:title' content='Travis Scott&#8217;s horrific concert could have been prevented' />
<meta name='twitter:image' content='http://ndsuspectrum.com/wp-content/uploads/2021/11/unnamed-6.png' />
<meta name='twitter:description' content='Concert-goers should never have to experience something like the Astroworld tragedyA concert is made for making you feel alive. Travis Scott&rsquo;s Astroworld Festival incident should not have happened. Travis Scott and his team should have stopped the show. Someone should have told him, &quot;Hey, peop' />
<!-- End Complete Open Graph. | 0.0029630661010742s -->

<link rel="image_src" href="http://ndsuspectrum.com/wp-content/uploads/2021/11/unnamed-6-300x200.png" /><!-- Facebook Pixel Code for Business account -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '146509472638188');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=146509472638188&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->



<!-- Facebook Pixel Code for Spectrum Ad account ending in 6842 -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '331727487296842');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=331727487296842&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<script>
  fbq('track', 'ViewContent');
</script>      <style>
      img.wp-post-image{ display: none !important; }
      </style>
      
						<style type="text/css">
														body,
					button,
					input,
					select,
					textarea {
						font-size: 16px;
					}
									/* Side Sidebar  Navigation*/
					.side-menu-wrap .side-nav-wrap a,
					.side-menu-wrap .side-nav-wrap ul li ul li a,
					.side-menu-wrap .side-nav-wrap ul li ul li ul li a {
						font-size: 24px;
					}
									/* Post Entry Titles */
					.entry-title {
						font-size: 24px;
					}
									/* Blockquote
					================================================== */
					blockquote {
						font-size: 18px;
					}
								</style>
			<meta name="viewport" content="width=device-width" />
	<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://ndsuspectrum.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://ndsuspectrum.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><style type="text/css">/** Mega Menu CSS: fs **/</style>
<style id="yellow-pencil">
/*
	The following CSS generated by YellowPencil Plugin.
	https://yellowpencil.waspthemes.com
*/
#site-title a{background-blend-mode:darken;background-image:url(http://ndsuspectrum.com/wp-content/uploads/2019/01/Spectrum-Logo-New-Long.jpg);color:rgb(34, 34, 34);-webkit-background-clip:padding-box;background-clip:padding-box;min-height:197px;background-repeat:repeat-x;-webkit-background-size:cover;background-size:cover;display:none;}#site-description{display:none;}#site-branding{-webkit-background-size:contain;background-size:contain;background-repeat:no-repeat;background-attachment:local;color:rgb(112, 112, 112);-webkit-background-clip:padding-box;background-clip:padding-box;background-blend-mode:darken;background-position:50% 50%;-webkit-animation-fill-mode:both;animation-fill-mode:both;-webkit-animation-iteration-count:1;animation-iteration-count:1;margin-bottom:0px !important;background-image:url(http://ndsuspectrum.com/wp-content/uploads/2019/01/Spectrum-Logo-New.jpg) !important;padding-bottom:86px;}.top-bar-wrap .widget .execphpwidget{min-height:48px;}.top-header .main-header .header-wrap-inner{padding-left:0px;-webkit-animation-fill-mode:both;animation-fill-mode:both;padding-bottom:0px;margin-bottom:15px;}.header-social-block ul a{-webkit-animation-fill-mode:both;animation-fill-mode:both;}.header-social-block ul a.yp_hover{-webkit-animation-delay:0s;animation-delay:0s;-webkit-animation-duration:1s;animation-duration:1s;-webkit-animation-name:pop;animation-name:pop;}#secondary{padding-left:34px;}#primary-menu > .menu-item > a{color:#ecf0f1;font-weight:600;}#primary-menu{-webkit-box-shadow:none;box-shadow:none;-webkit-animation-fill-mode:both;animation-fill-mode:both;background-color:rgba(45,45,45,0.96) !important;}#site-branding.yp_click{-webkit-animation-delay:0s;animation-delay:0s;-webkit-animation-duration:1s;animation-duration:1s;-webkit-animation-name:spin;animation-name:spin;}.g-1 a img{display:inline-block;height:60px;}.hentry blockquote{border-color:#7a7a7a;color:#2b2b2b;}@media (max-width:767px){.top-header .top-bar .top-bar-wrap{visibility:visible !important;}}@media (max-width:319px){.top-header .top-bar .top-bar-wrap{position:relative;visibility:visible;}#page #masthead .header-wrap .top-header .top-bar .top-bar-wrap{width:auto !important;height:auto !important;-webkit-box-sizing:content-box !important;box-sizing:content-box !important;}}
</style></head>
<body class="post-template-default single single-post postid-109005 single-format-standard wp-embed-responsive  boxed-layout gutenberg wpb-js-composer js-comp-ver-4.11.1 vc_responsive">
	<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#site-content-contain">Skip to content</a>
	<!-- Masthead ============================================= -->
	<header id="masthead" class="site-header" role="banner">
		<div class="header-wrap">
			<!-- Top Header============================================= -->
			<div class="top-header">
									<div class="top-bar">
						<div class="top-bar-wrap">
							<aside id="execphp-4" class="widget widget_contact"><h3 class="widget-title">Date</h3>			<div class="execphpwidget">
Wed,  November 17, 2021 Edition
 </div>
		</aside><aside id="adrotate_widgets-27" class="widget widget_contact"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside>						</div> <!-- end .top-bar-wrap -->
					</div> <!-- end .top-bar -->
								<!-- Main Header============================================= -->
				<div class="main-header clearfix">
					<div class="header-wrap-inner">
						<div class="header-left">
														<div class="header-social-block">
									<div class="social-links clearfix">
	<ul><li id="menu-item-40923" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40923"><a href="https://www.facebook.com/ndsuspectrum/"><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-40924" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40924"><a href="https://twitter.com/ndsuspectrum?lang=en"><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-75557" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-75557"><a href="https://www.instagram.com/ndsu.spectrum/"><span class="screen-reader-text">instagram</span></a></li>
</ul>	</div><!-- end .social-links -->
								</div>
														</div> <!-- end .header-left -->
					

						<div id="site-branding" class="site-branding"><div id="site-detail"> <h2 id="site-title"> 				<a href="http://ndsuspectrum.com/" title="the Spectrum" rel="home"> the Spectrum </a>
				 </h2> <!-- end .site-title --> 					<div id="site-description"> For the Land and its People </div> <!-- end #site-description -->
			
		</div></div>
						<div class="header-right">
															<button id="search-toggle" class="header-search" type="button"></button>
										<div id="search-box" class="clearfix">
											<div class="search-x"></div>
												<form class="search-form" action="http://ndsuspectrum.com/" method="get" role="search">
			<label class="screen-reader-text">Search …</label>
		<input type="search" name="s" class="search-field" placeholder="Search …" autocomplete="off" />
		<button type="submit" class="search-submit"><i class="fa fa-search"></i></button>
</form> <!-- end .search-form -->										</div>  <!-- end #search-box -->
															</div> <!-- end .header-right -->
					</div> <!-- end .wrap -->

											<!-- Main Nav ============================================= -->
						<div id="sticky-header" class="clearfix">
							<nav id="site-navigation" class="main-navigation clearfix" role="navigation" aria-label="Main Menu">

							<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
								<span class="line-bar"></span>
						  	</button> <!-- end .menu-toggle -->
							
								<ul id="primary-menu" class="menu nav-menu"><li id="menu-item-460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-460"><a href="http://www.ndsuspectrum.com">Home</a></li>
<li id="menu-item-4013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4013"><a href="http://ndsuspectrum.com/category/news/">News</a></li>
<li id="menu-item-107046" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-107046"><a href="http://ndsuspectrum.com/category/variety/">Variety</a>
<ul class="sub-menu">
	<li id="menu-item-107050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107050"><a href="http://ndsuspectrum.com/category/variety/features/">Features</a></li>
	<li id="menu-item-107047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107047"><a href="http://ndsuspectrum.com/category/variety/arts-entertainment/music-ae/">Music</a></li>
	<li id="menu-item-107048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107048"><a href="http://ndsuspectrum.com/category/variety/arts-entertainment/movies/">Movies</a></li>
	<li id="menu-item-107049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107049"><a href="http://ndsuspectrum.com/category/variety/arts-entertainment/videogames/">Video Games</a></li>
</ul>
</li>
<li id="menu-item-821" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-821"><a href="http://ndsuspectrum.com/category/opinion/">Opinion</a></li>
<li id="menu-item-824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-824"><a href="http://ndsuspectrum.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-826"><a href="http://ndsuspectrum.com/category/sports/bball/">College Basketball</a></li>
	<li id="menu-item-828" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-828"><a href="http://ndsuspectrum.com/category/sports/football/">College Football</a></li>
	<li id="menu-item-833" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-833"><a href="http://ndsuspectrum.com/category/sports/vball/">College Volleyball</a></li>
	<li id="menu-item-103356" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-103356"><a href="http://ndsuspectrum.com/category/sports/pro-sports/">Pro Sports</a></li>
</ul>
</li>
<li id="menu-item-75588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-75588"><a href="http://ndsuspectrum.com/hiring">Hiring</a></li>
</ul>							</nav> <!-- end #site-navigation -->
						</div> <!-- end #sticky-header -->
									</div> <!-- end .main-header -->
			</div> <!-- end .top-header -->

					</div> <!-- end .header-wrap -->
	</header> <!-- end #masthead -->
	<!-- Main Page Start ============================================= -->
	<div id="site-content-contain" class="site-content-contain">
		<div id="content" class="site-content">
					
<div class="wrap">
	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">
			<article id="post-109005" class="post-109005 post type-post status-publish format-standard has-post-thumbnail hentry category-opinion tag-astroworld tag-music-festival tag-travis-scott">
									<div class="entry-thumb">
						<figure class="entry-thumb-content">
							<img width="512" height="342" src="http://ndsuspectrum.com/wp-content/uploads/2021/11/unnamed-6.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" loading="lazy" srcset="http://ndsuspectrum.com/wp-content/uploads/2021/11/unnamed-6.png 512w, http://ndsuspectrum.com/wp-content/uploads/2021/11/unnamed-6-300x200.png 300w" sizes="(max-width: 512px) 100vw, 512px" />						</figure>
					</div> <!-- end .entry-thumb -->
								 <header class="entry-header">
											<div class="entry-meta">
															<span class="cat-links">
									<ul class="post-categories">
	<li><a href="http://ndsuspectrum.com/category/opinion/" rel="category tag">Opinion</a></li></ul>								</span> <!-- end .cat-links -->
															<span class="tag-links">
									<a href="http://ndsuspectrum.com/tag/astroworld/" rel="tag">Astroworld</a><a href="http://ndsuspectrum.com/tag/music-festival/" rel="tag">music festival</a><a href="http://ndsuspectrum.com/tag/travis-scott/" rel="tag">Travis Scott</a>								</span> <!-- end .tag-links -->
													</div> <!-- end .entry-meta -->
										<h2 class="entry-title"> <a href="http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/" title="Travis Scott&#8217;s horrific concert could have been prevented"> Travis Scott&#8217;s horrific concert could have been prevented </a> </h2> <!-- end.entry-title -->
											<div class="entry-meta">
							<span class="author vcard"><a href="http://ndsuspectrum.com/author/kileeblume/" title="Travis Scott&#8217;s horrific concert could have been prevented"><i class="fa fa-user-o"></i> Kilee Blume</a></span><span class="posted-on"><a href="http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/" title="November 16, 2021"><i class="fa fa-calendar-o"></i> November 16, 2021 </a></span>									<span class="comments">
									<a href="http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/#respond"><i class="fa fa-comment-o"></i> No Comments</a> </span>
													</div> <!-- end .entry-meta -->
									</header><!-- end .entry-header -->
				<div class="entry-content">
					
<h3>Concert-goers should never have to experience something like the Astroworld tragedy</h3>



<p>A concert is made for making you feel alive. Travis Scott’s Astroworld Festival incident should not have happened. Travis Scott and his team should have stopped the show. Someone should have told him, &#8220;Hey, people are getting trampled and hurt, let’s stop the show, help everyone up and make sure that everyone is OK.&#8221; But that’s not what happened. </p>



<p>According to ABC News, around 9:30 p.m. at the Astroworld event a crowd began to compress toward the front of the stage, said Houston Fire Chief Sam Pena. A resident of San Antonio, Fatima Munoz, 21, had described the event as a “domino effect.” Everyone had fallen on the floor, including him, as he tried so hard to get up.  </p>



<p>ABC News goes on to say that Scott had continued the show. Only pausing when he noticed someone in the crowd passed out. Around 300 people had been treated by medical personnel on site, while another 25 had been transported to the hospital. </p>



<p>While investigating, Houston Fire Chief believes that Travis Scott should have at least tried stopping the show. Travis Scott was the biggest influence at the show, he could have easily stopped and had his team make sure everyone was okay. You would think that if you saw a huge group of people just fall over in the crowd, there is obviously something wrong. </p>



<p>While medical professionals came to help those who were struggling, Travis should have realized that something wasn’t right. Or his team should have let him know and the show could’ve been stopped. If Travis would’ve stopped the show, none of this would’ve happened. </p>



<p>Along with this, Travis should have a team that is communicating with him about what is going on, along with having a security team that does not allow as many people into the concert venue. </p>



<p>To avoid this in the future, the concert should be split into multiple days, with the same headliners and the same show. Rather than the unfortunate domino effect that happened last Saturday. To add onto this, the performer must have a strong security system that will help prevent tragic effects like this happening in the future. </p>



<figure class="wp-block-pullquote"><blockquote><p>People go to concerts to feel alive; at Travis Scott’s Astroworld concert — it was quite the opposite. It is unfortunate and my heart goes out to all the families of those who have died and to all of the concertgoers that were looking forward to the time of their life.</p></blockquote></figure>



<p>According to Today, eight people ranging from 14 to 27 died from the tragedy of Travis Scott’s concert. Kylie Jenner went to Instagram to express that she and Travis, “weren’t aware of any fatalities until the news came out after the show and in no world would have continued filming or performing.” </p>



<p>If this is true, Travis Scott should have his security team terminated and a new stronger, more professional team should take their place. They need to take their job seriously. And if Travis were to realize what was happening, the show should have ended right then and there.&nbsp;</p>



<p>Today, goes on to state, “Scott announced Monday he will pay for the funeral costs of those who died and will offer free one-on-one therapy and other mental health services for those affected by the tragedy, through the partnership with therapy company, BetterHelp.”</p>



<p>It is good to see that Travis Scott is offering help to the families and concert-goers that were affected by this horrific event. However, there should be some charges toward him or his team for what had happened in the first place. </p>



<p>Today said that “Scott previously pled guilty to charges in 2015 and 2017 after incidents involving fans rushing to the stage and jumping barricades at concerts in Chicago and Arkansas.” Personally, if I had pled guilty for these charges — I know I wouldn’t have let it happen again. </p>



<p>Even though the investigation isn’t over, I believe that there should be consequences at the end of it all. People go to concerts to feel alive; at Travis Scott’s Astroworld concert — it was quite the opposite. It is unfortunate and my heart goes out to all the families of those who have passed and to all of the concertgoers that were looking forward to the time of their life. </p>



<p>A lesson should be learned from this horrific incident. </p>



<p><em>Note: there have been 10 total deaths related to the Astroworld event as of Nov. 15, 2021.</em></p>
<div class="tptn_counter" id="tptn_counter_109005"><script type="text/javascript" data-cfasync="false" src="http://ndsuspectrum.com/?top_ten_id=109005&amp;view_counter=1&amp;_wpnonce=056affba1c"></script></div>			
				</div><!-- end .entry-content -->
				
<div id="comments" class="comments-area">
				<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/travis-scotts-horrific-concert-could-have-been-prevented/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="http://ndsuspectrum.com/wp-login.php?redirect_to=http%3A%2F%2Fndsuspectrum.com%2Ftravis-scotts-horrific-concert-could-have-been-prevented%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	</div> <!-- .comments-area -->			</article><!-- end .post -->
			
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://ndsuspectrum.com/vaccine-lawsuit-adds-nd-with-the-state-joining-9-others/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">Vaccine lawsuit adds ND with the state joining 9 others</span></a></div></div>
	</nav>		</main><!-- end #main -->
	</div> <!-- end #primary -->
	
<aside id="secondary" class="widget-area" role="complementary">
    <aside id="adrotate_widgets-22" class="widget adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside><aside id="adrotate_widgets-23" class="widget adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside><aside id="adrotate_widgets-24" class="widget adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside><aside id="adrotate_widgets-28" class="widget adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside><aside id="adrotate_widgets-29" class="widget adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside>
		<aside id="recent-posts-7" class="widget widget_recent_entries">
		<h2 class="widget-title">Recent Posts</h2>
		<ul>
											<li>
					<a href="http://ndsuspectrum.com/travis-scotts-horrific-concert-could-have-been-prevented/" aria-current="page">Travis Scott&#8217;s horrific concert could have been prevented</a>
											<span class="post-date">November 16, 2021</span>
									</li>
											<li>
					<a href="http://ndsuspectrum.com/staying-sane-in-fargos-winter-months/">Staying sane in Fargo’s winter months</a>
											<span class="post-date">November 16, 2021</span>
									</li>
											<li>
					<a href="http://ndsuspectrum.com/vaccine-lawsuit-adds-nd-with-the-state-joining-9-others/">Vaccine lawsuit adds ND with the state joining 9 others</a>
											<span class="post-date">November 15, 2021</span>
									</li>
											<li>
					<a href="http://ndsuspectrum.com/astrofest-what-is-travis-scotts-next-move/">Astrofest: What is Travis Scott’s next move?</a>
											<span class="post-date">November 15, 2021</span>
									</li>
											<li>
					<a href="http://ndsuspectrum.com/in-a-nutshell-19/">In a nutshell</a>
											<span class="post-date">November 12, 2021</span>
									</li>
					</ul>

		</aside></aside><!-- end #secondary -->
</div><!-- end .wrap -->
</div><!-- end #content -->
		<!-- Footer Start ============================================= -->
		<footer id="colophon" class="site-footer" role="contentinfo">
				<div class="widget-wrap">
			<div class="wrap">
				<div class="widget-area">
					<div class="column-4"><aside id="meta-8" class="widget widget_meta"><h3 class="widget-title">Meta</h3>
		<ul>
						<li><a rel="nofollow" href="http://ndsuspectrum.com/wp-login.php">Log in</a></li>
			<li><a href="http://ndsuspectrum.com/feed/">Entries feed</a></li>
			<li><a href="http://ndsuspectrum.com/comments/feed/">Comments feed</a></li>

			<li><a href="https://wordpress.org/">WordPress.org</a></li>
		</ul>

		</aside></div><!-- end .column4  --><div class="column-4"><aside id="text-4" class="widget widget_text"><h3 class="widget-title">Advertise</h3>			<div class="textwidget"><p><a href="http://ndsuspectrum.com/advertise/">Advertise with us!</a></p>
<p><a href="http://ndsuspectrum.com/place-a-classified/">Place a Classified</a></p>
<p><a href="http://ndsuspectrum.com/place-a-display-ad/">Place a Display</a></p>
</div>
		</aside></div><!--end .column4  --><div class="column-4"><aside id="text-6" class="widget widget_text"><h3 class="widget-title">Contact</h3>			<div class="textwidget"><p><a href="http://ndsuspectrum.com/about">About</a></p>
<p><a href="http://ndsuspectrum.com/staff">Staff</a></p>
<p><a href="http://ndsuspectrum.com/contact/">Contact us!</a></p>
<p>&nbsp;</p>
</div>
		</aside></div><!--end .column4  --><div class="column-4"><aside id="text-7" class="widget widget_text"><h3 class="widget-title">More</h3>			<div class="textwidget"><p><a href="http://ndsuspectrum.com/latest-issue/">Latest Issue</a></p>
<p><a href="http://ndsuspectrum.com/classifieds">Classifieds</a></p>
</div>
		</aside></div><!--end .column4-->				</div> <!-- end .widget-area -->
			</div> <!-- end .wrap -->
		</div> <!-- end .widget-wrap -->
	
			<!-- Site Information ============================================= -->
			<div class="site-info"  >
				<div class="wrap">
						<div class="social-links clearfix">
	<ul><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40923"><a href="https://www.facebook.com/ndsuspectrum/"><span class="screen-reader-text">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40924"><a href="https://twitter.com/ndsuspectrum?lang=en"><span class="screen-reader-text">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-75557"><a href="https://www.instagram.com/ndsu.spectrum/"><span class="screen-reader-text">instagram</span></a></li>
</ul>	</div><!-- end .social-links -->
						<div class="copyright">
					<div id="text-9" class="copyright widget_text">			<div class="textwidget"><p>@ NDSU SPECTRUM 2019</p>
</div>
		</div><div id="search-2" class="copyright widget_search"><form class="search-form" action="http://ndsuspectrum.com/" method="get" role="search">
			<label class="screen-reader-text">Search …</label>
		<input type="search" name="s" class="search-field" placeholder="Search …" autocomplete="off" />
		<button type="submit" class="search-submit"><i class="fa fa-search"></i></button>
</form> <!-- end .search-form --></div><div id="adrotate_widgets-18" class="copyright adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></div><div id="adrotate_widgets-5" class="copyright adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></div><div id="ritsocialwidget-3" class="copyright RITSocialWidget"><div class="eva-social-icon clearfix"><a href="http://www.facebook.com//ndsuspectrum" target="_blank" title="ion-social-facebook" class="ion-social-facebook"><i class="fa fa-facebook"></i></a><a href="http://twitter.com//NDSUSpectrum" target="_blank" title="ion-social-twitter" class="ion-social-twitter"><i class="fa fa-twitter"></i></a><a href="http://instagram.com/thespectrumndsu" target="_blank" title="ion-social-instagram" class="ion-social-instagram"><i class="fa fa-instagram"></i></a></div></div><div id="widget_tptn_pop-5" class="copyright tptn_posts_list_widget"><h2 class="widgettitle">Most Popular Posts</h2>
<div class="tptn_posts  tptn_posts_widget tptn_posts_widget5"><ul><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/britney-has-been-freed/"     class="tptn_link"><span class="tptn_title">Britney has been #freed</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/kileeblume/">Kilee Blume</a></span> <span class="tptn_date"> November 10, 2021</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/trouble-with-the-raiders/"     class="tptn_link"><span class="tptn_title">Trouble with the Raiders</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/masonurban/">Mason Urban</a></span> <span class="tptn_date"> November 11, 2021</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/stop-forcing-the-covid-19-vaccine/"     class="tptn_link"><span class="tptn_title">Stop forcing the Covid-19 vaccine</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/kileeblume/">Kilee Blume</a></span> <span class="tptn_date"> November 4, 2021</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/is-patrick-mahomes-seeing-ghosts/"     class="tptn_link"><span class="tptn_title">Is Patrick Mahomes seeing ghosts?</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/dallas-korelc/">Dallas Korelc</a></span> <span class="tptn_date"> October 27, 2021</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/why-tucker-carlson-sucks/"     class="tptn_link"><span class="tptn_title">Why Tucker Carlson sucks</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/abigailfaulkner/">Abigail Faulkner</a></span> <span class="tptn_date"> November 9, 2021</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/the-haunted-north-dakota-sanitarium/"     class="tptn_link"><span class="tptn_title">The Haunted North Dakota Sanitarium</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/alissaknudson/">Alissa Knudson</a></span> <span class="tptn_date"> October 27, 2021</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/squid-game-red-light-or-green-light/"     class="tptn_link"><span class="tptn_title">Squid Game — Red Light or Green Light?</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/andrew-werlinger/">Andrew Werlinger</a></span> <span class="tptn_date"> October 19, 2021</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/apple-releases-new-shareplay-feature-to-public/"     class="tptn_link"><span class="tptn_title">Apple releases new ‘Shareplay’ feature to public</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/grantayers/">Grant Ayers</a></span> <span class="tptn_date"> November 9, 2021</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/nfl-mvp-update/"     class="tptn_link"><span class="tptn_title">NFL MVP update</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/masonurban/">Mason Urban</a></span> <span class="tptn_date"> October 22, 2021</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/astrofest-what-is-travis-scotts-next-move/"     class="tptn_link"><span class="tptn_title">Astrofest: What is Travis Scott’s next move?</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/grantayers/">Grant Ayers</a></span> <span class="tptn_date"> November 15, 2021</span> </span></li></ul><div class="tptn_clear"></div></div></div>					</div><!-- end .copyright -->
					<div style="clear:both;"></div>
				</div> <!-- end .wrap -->
			</div> <!-- end .site-info -->
								<button class="go-to-top" type="button">
						<span class="screen-reader-text">Go to top</span>
						<span class="icon-bg"></span>
							 <span class="back-to-top-text">Top</span>
							<i class="fa fa-angle-up back-to-top-icon"></i>
					</button>
						<div class="page-overlay"></div>
		</footer> <!-- end #colophon -->
	</div><!-- end .site-content-contain -->
</div><!-- end #page -->
<script type='text/javascript' id='jshowoff-adrotate-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"http:\/\/ndsuspectrum.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js' id='jshowoff-adrotate-js'></script>
<script type='text/javascript' id='clicktrack-adrotate-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/ndsuspectrum.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js' id='clicktrack-adrotate-js'></script>
<script type='text/javascript' src='//www.google.com/recaptcha/api.js?ver=7.8.5&#038;onload=ccfRecaptchaOnload&#038;render=explicit' id='ccf-google-recaptcha-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/rit-core/assets/js/masonry.pkgd.min.js?ver=2.0' id='rit-masonry-js-js'></script>
<script type='text/javascript' id='tptn_tracker-js-extra'>
/* <![CDATA[ */
var ajax_tptn_tracker = {"ajax_url":"http:\/\/ndsuspectrum.com\/wp-admin\/admin-ajax.php","top_ten_id":"109005","top_ten_blog_id":"1","activate_counter":"11","top_ten_debug":"0","tptn_rnd":"547045753"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/top-10/includes/js/top-10-tracker.min.js?ver=1.0' id='tptn_tracker-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/comment-reply.min.js?ver=5.8.2' id='comment-reply-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/backbone.min.js?ver=1.4.0' id='backbone-js'></script>
<script type='text/javascript' id='wp-api-ccf-js-extra'>
/* <![CDATA[ */
var WP_API_Settings = {"root":"http:\/\/ndsuspectrum.com\/wp-json\/","nonce":"55fd7d9567"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/custom-contact-forms/wp-api/wp-api.js?ver=1.2' id='wp-api-ccf-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/themes/cocktail/js/cocktail-main.js?ver=5.8.2' id='cocktail-main-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/themes/cocktail/assets/sticky/jquery.sticky.min.js?ver=5.8.2' id='jquery-sticky-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/themes/cocktail/assets/sticky/sticky-settings.js?ver=5.8.2' id='cocktail-sticky-settings-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/themes/cocktail/js/navigation.js?ver=5.8.2' id='cocktail-navigation-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/themes/cocktail/js/skip-link-focus-fix.js?ver=5.8.2' id='cocktail-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/hoverIntent.min.js?ver=1.10.1' id='hoverIntent-js'></script>
<script type='text/javascript' id='megamenu-js-extra'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.9.3' id='megamenu-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({ groupid: 1, speed: 6000 });
	jQuery('.g-2').gslider({ groupid: 2, speed: 6000 });
	jQuery('.g-4').gslider({ groupid: 4, speed: 6000 });
	jQuery('.g-5').gslider({ groupid: 5, speed: 6000 });
}
});
</script>
<!-- /AdRotate JS -->

</body>
</html>
<!-- Dynamic page generated in 1.999 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2021-11-17 06:26:29 -->

<!-- super cache -->