<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# website: http://ogp.me/ns/website#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="http://ndsuspectrum.com/xmlrpc.php">
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Recap: RuPaul&#039;s Drag Race - the Spectrum</title>
	<link rel="canonical" href="http://ndsuspectrum.com/recap-rupauls-drag-race-7/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Recap: RuPaul&#039;s Drag Race - the Spectrum" />
	<meta property="og:description" content="Spilling the tea on season 14, episode eight *Warning* The following article contains spoilers for RuPaul’s Drag Race season 14, episode eight. The queens reenter &quot;Recap: RuPaul&#8217;s Drag Race&quot;" />
	<meta property="og:url" content="http://ndsuspectrum.com/recap-rupauls-drag-race-7/" />
	<meta property="og:site_name" content="the Spectrum" />
	<meta property="article:publisher" content="https://www.facebook.com/ndsuspectrum" />
	<meta property="article:published_time" content="2022-02-28T14:00:00+00:00" />
	<meta property="article:modified_time" content="2022-02-28T04:53:11+00:00" />
	<meta property="og:image" content="http://ndsuspectrum.com/wp-content/uploads/2022/02/RuPaul-Season-14-VH1-1.jpeg" />
	<meta property="og:image:width" content="681" />
	<meta property="og:image:height" content="383" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@NDSUSpectrum" />
	<meta name="twitter:site" content="@NDSUSpectrum" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Brayden Zenker" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="8 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://ndsuspectrum.com/#organization","name":"The Spectrum","url":"http://ndsuspectrum.com/","sameAs":["https://www.facebook.com/ndsuspectrum","https://instagram.com/thespectrumndsu/","https://twitter.com/NDSUSpectrum"],"logo":{"@type":"ImageObject","@id":"http://ndsuspectrum.com/#logo","inLanguage":"en-US","url":"http://ndsuspectrum.com/wp-content/uploads/2014/02/new_web_logo.jpg","contentUrl":"http://ndsuspectrum.com/wp-content/uploads/2014/02/new_web_logo.jpg","width":600,"height":98,"caption":"The Spectrum"},"image":{"@id":"http://ndsuspectrum.com/#logo"}},{"@type":"WebSite","@id":"http://ndsuspectrum.com/#website","url":"http://ndsuspectrum.com/","name":"the Spectrum","description":"For the Land and its People","publisher":{"@id":"http://ndsuspectrum.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"http://ndsuspectrum.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"http://ndsuspectrum.com/recap-rupauls-drag-race-7/#primaryimage","inLanguage":"en-US","url":"http://ndsuspectrum.com/wp-content/uploads/2022/02/RuPaul-Season-14-VH1-1.jpeg","contentUrl":"http://ndsuspectrum.com/wp-content/uploads/2022/02/RuPaul-Season-14-VH1-1.jpeg","width":681,"height":383},{"@type":"WebPage","@id":"http://ndsuspectrum.com/recap-rupauls-drag-race-7/#webpage","url":"http://ndsuspectrum.com/recap-rupauls-drag-race-7/","name":"Recap: RuPaul's Drag Race - the Spectrum","isPartOf":{"@id":"http://ndsuspectrum.com/#website"},"primaryImageOfPage":{"@id":"http://ndsuspectrum.com/recap-rupauls-drag-race-7/#primaryimage"},"datePublished":"2022-02-28T14:00:00+00:00","dateModified":"2022-02-28T04:53:11+00:00","breadcrumb":{"@id":"http://ndsuspectrum.com/recap-rupauls-drag-race-7/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["http://ndsuspectrum.com/recap-rupauls-drag-race-7/"]}]},{"@type":"BreadcrumbList","@id":"http://ndsuspectrum.com/recap-rupauls-drag-race-7/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"http://ndsuspectrum.com/"},{"@type":"ListItem","position":2,"name":"Recap: RuPaul&#8217;s Drag Race"}]},{"@type":"Article","@id":"http://ndsuspectrum.com/recap-rupauls-drag-race-7/#article","isPartOf":{"@id":"http://ndsuspectrum.com/recap-rupauls-drag-race-7/#webpage"},"author":{"@id":"http://ndsuspectrum.com/#/schema/person/ea8dce2ba1e2c690c0e45c02cc595d0b"},"headline":"Recap: RuPaul&#8217;s Drag Race","datePublished":"2022-02-28T14:00:00+00:00","dateModified":"2022-02-28T04:53:11+00:00","mainEntityOfPage":{"@id":"http://ndsuspectrum.com/recap-rupauls-drag-race-7/#webpage"},"wordCount":1703,"commentCount":0,"publisher":{"@id":"http://ndsuspectrum.com/#organization"},"image":{"@id":"http://ndsuspectrum.com/recap-rupauls-drag-race-7/#primaryimage"},"thumbnailUrl":"http://ndsuspectrum.com/wp-content/uploads/2022/02/RuPaul-Season-14-VH1-1.jpeg","articleSection":["Arts &amp; Entertainment","TV","Variety"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["http://ndsuspectrum.com/recap-rupauls-drag-race-7/#respond"]}]},{"@type":"Person","@id":"http://ndsuspectrum.com/#/schema/person/ea8dce2ba1e2c690c0e45c02cc595d0b","name":"Brayden Zenker","image":{"@type":"ImageObject","@id":"http://ndsuspectrum.com/#personlogo","inLanguage":"en-US","url":"http://0.gravatar.com/avatar/33283ec88c49d749dffa7273e87af605?s=96&d=mm&r=g","contentUrl":"http://0.gravatar.com/avatar/33283ec88c49d749dffa7273e87af605?s=96&d=mm&r=g","caption":"Brayden Zenker"},"url":"http://ndsuspectrum.com/author/braydenzenker/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="the Spectrum &raquo; Feed" href="http://ndsuspectrum.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="the Spectrum &raquo; Comments Feed" href="http://ndsuspectrum.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="the Spectrum &raquo; Recap: RuPaul&#8217;s Drag Race Comments Feed" href="http://ndsuspectrum.com/recap-rupauls-drag-race-7/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.3.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-49923412-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/ndsuspectrum.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://ndsuspectrum.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='ccf-jquery-ui-css'  href='//ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/themes/smoothness/jquery-ui.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='ccf-form-css'  href='http://ndsuspectrum.com/wp-content/plugins/custom-contact-forms/assets/build/css/form.min.css?ver=7.8.5' type='text/css' media='all' />
<link rel='stylesheet' id='rit-core-front-css-css'  href='http://ndsuspectrum.com/wp-content/plugins/rit-core/assets/css/rit-core-front.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='rit-blog-css-css'  href='http://ndsuspectrum.com/wp-content/plugins/rit-core/assets/css/blog-style.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='rit-masonry-css-css'  href='http://ndsuspectrum.com/wp-content/plugins/rit-core/assets/css/rit-masonry.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='rit-news-css-css'  href='http://ndsuspectrum.com/wp-content/plugins/rit-core/assets/css/rit-news.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='rit-social-counter-frontend-css-css'  href='http://ndsuspectrum.com/wp-content/plugins/rit-core/inc/social-counter/css/rit-social-counter-frontend.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='yop-public-css'  href='http://ndsuspectrum.com/wp-content/plugins/yop-poll/public/assets/css/yop-poll-public-6.3.3.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='cocktail-styles-css'  href='http://ndsuspectrum.com/wp-content/plugins/cocktail-plus/inc/css/cocktail-styles.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='cocktail-google-fonts-css'  href='//fonts.googleapis.com/css?family=Lora%7CNoto+Sans%3A300%2C400%2C400i%2C500%2C600%2C700&#038;ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://ndsuspectrum.com/wp-includes/css/dashicons.min.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='cocktail-style-css'  href='http://ndsuspectrum.com/wp-content/themes/cocktail/style.css?ver=5.9.1' type='text/css' media='all' />
<style id='cocktail-style-inline-css' type='text/css'>
/* Header Image With background Text color */
		.header-image-title {
			background-color: rgba(0,0,0,0.3);
			padding: 8px 26px;
			width: auto;
		}
.header-image-title {
				left: 50%;
				top: 50%;
				transform: translate(-50%, -50%);
				right: auto;
				bottom: auto;
				text-align: center;
			}
</style>
<link rel='stylesheet' id='font-awesome-css'  href='http://ndsuspectrum.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?ver=4.11.1' type='text/css' media='all' />
<link rel='stylesheet' id='cocktail-responsive-css'  href='http://ndsuspectrum.com/wp-content/themes/cocktail/css/responsive.css?ver=5.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='yellow-pencil-animate-css'  href='http://ndsuspectrum.com/wp-content/plugins/waspthemes-yellow-pencil/library/css/animate.css?ver=5.9.1' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"http:\/\/ndsuspectrum.com","hash_tracking":"false","ua":"UA-49923412-1","v4_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.3.2' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/jquery/ui/core.min.js?ver=1.13.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.13.1' id='jquery-ui-datepicker-js'></script>
<script type='text/javascript' id='jquery-ui-datepicker-js-after'>
jQuery(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' id='ccf-form-js-extra'>
/* <![CDATA[ */
var ccfSettings = {"ajaxurl":"http:\/\/ndsuspectrum.com\/wp-admin\/admin-ajax.php","required":"This field is required.","date_required":"Date is required.","hour_required":"Hour is required.","minute_required":"Minute is required.","am-pm_required":"AM\/PM is required.","match":"Emails do not match.","email":"This is not a valid email address.","recaptcha":"Your reCAPTCHA response was incorrect.","recaptcha_theme":"light","phone":"This is not a valid phone number.","digits":"This phone number is not 10 digits","hour":"This is not a valid hour.","date":"This date is not valid.","minute":"This is not a valid minute.","fileExtension":"This is not an allowed file extension","fileSize":"This file is bigger than","unknown":"An unknown error occured.","website":"This is not a valid URL. URL's must start with http(s):\/\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/custom-contact-forms/assets/build/js/form.min.js?ver=7.8.5' id='ccf-form-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/rit-core/assets/js/rit-core-front.js?ver=2.0' id='rit-core-front-js-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/waspthemes-yellow-pencil/library/js/animation-events.js?ver=5.9.1' id='yellow-pencil-library-js'></script>
<script type='text/javascript' id='yop-public-js-extra'>
/* <![CDATA[ */
var objectL10n = {"yopPollParams":{"urlParams":{"ajax":"http:\/\/ndsuspectrum.com\/wp-admin\/admin-ajax.php","wpLogin":"http:\/\/ndsuspectrum.com\/wp-login.php?redirect_to=http%3A%2F%2Fndsuspectrum.com%2Fwp-admin%2Fadmin-ajax.php%3Faction%3Dyop_poll_record_wordpress_vote"},"apiParams":{"reCaptcha":{"siteKey":""},"reCaptchaV2Invisible":{"siteKey":""},"reCaptchaV3":{"siteKey":""}},"captchaParams":{"imgPath":"http:\/\/ndsuspectrum.com\/wp-content\/plugins\/yop-poll\/public\/assets\/img\/","url":"http:\/\/ndsuspectrum.com\/wp-content\/plugins\/yop-poll\/app.php","accessibilityAlt":"Sound icon","accessibilityTitle":"Accessibility option: listen to a question and answer it!","accessibilityDescription":"Type below the <strong>answer<\/strong> to what you hear. Numbers or words:","explanation":"Click or touch the <strong>ANSWER<\/strong>","refreshAlt":"Refresh\/reload icon","refreshTitle":"Refresh\/reload: get new images and accessibility option!"},"voteParams":{"invalidPoll":"Invalid Poll","noAnswersSelected":"No answer selected","minAnswersRequired":"At least {min_answers_allowed} answer(s) required","maxAnswersRequired":"A max of {max_answers_allowed} answer(s) accepted","noAnswerForOther":"No other answer entered","noValueForCustomField":"{custom_field_name} is required","consentNotChecked":"You must agree to our terms and conditions","noCaptchaSelected":"Captcha is required","thankYou":"Thank you for your vote"},"resultsParams":{"singleVote":"vote","multipleVotes":"votes","singleAnswer":"answer","multipleAnswers":"answers"}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/yop-poll/public/assets/js/yop-poll-public-6.3.3.min.js?ver=5.9.1' id='yop-public-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/themes/cocktail/js/html5.js?ver=3.7.3' id='html5-js'></script>
<![endif]-->
<link rel="https://api.w.org/" href="http://ndsuspectrum.com/wp-json/" /><link rel="alternate" type="application/json" href="http://ndsuspectrum.com/wp-json/wp/v2/posts/111175" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://ndsuspectrum.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://ndsuspectrum.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.1" />
<link rel='shortlink' href='http://ndsuspectrum.com/?p=111175' />
<link rel="alternate" type="application/json+oembed" href="http://ndsuspectrum.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fndsuspectrum.com%2Frecap-rupauls-drag-race-7%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://ndsuspectrum.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fndsuspectrum.com%2Frecap-rupauls-drag-race-7%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.21 to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:1px 1px 1px 1px;width:100%; max-width:468px; height:100%; max-height:60px; float:right; clear:right; }
	.g-2 { margin:1px 1px 1px 1px;width:100%; max-width:350px; height:100%; max-height:250px; }
	.g-3 { margin:1px;  }
	.g-4 { margin:1px 1px 1px 1px;width:100%; max-width:300px; height:100%; max-height:450px; }
	.g-5 { margin:1px 1px 1px 1px;width:100%; max-width:250px; height:100%; max-height:300px; }
	.g-6 { margin:1px 0px 0px 0px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->



<!-- Open Graph data is managed by Alex MacArthur's Complete Open Graph plugin. (v3.4.5) -->
<!-- https://wordpress.org/plugins/complete-open-graph/ -->
<meta property='og:site_name' content='the Spectrum' />
<meta property='og:url' content='http://ndsuspectrum.com/recap-rupauls-drag-race-7/' />
<meta property='og:locale' content='en_US' />
<meta property='og:description' content='Spilling the tea on season 14, episode eightPhoto Credit | VH1 | RuPaul&#039;s Drag RaceThe cast of season 14 of RuPaul&#039;s Drag Race. *Warning* The following article contains spoilers for RuPaul&rsquo;s Drag Race season 14, episode eight.The queens reenter the werkroom with spirits high after the ' />
<meta property='og:title' content='Recap: RuPaul&#8217;s Drag Race' />
<meta property='og:type' content='article' />
<meta property='og:image' content='http://ndsuspectrum.com/wp-content/uploads/2022/02/RuPaul-Season-14-VH1-1.jpeg' />
<meta property='og:image:width' content='681' />
<meta property='og:image:height' content='383' />
<meta name='twitter:card' content='summary' />
<meta name='twitter:title' content='Recap: RuPaul&#8217;s Drag Race' />
<meta name='twitter:image' content='http://ndsuspectrum.com/wp-content/uploads/2022/02/RuPaul-Season-14-VH1-1.jpeg' />
<meta name='twitter:description' content='Spilling the tea on season 14, episode eightPhoto Credit | VH1 | RuPaul&#039;s Drag RaceThe cast of season 14 of RuPaul&#039;s Drag Race. *Warning* The following article contains spoilers for RuPaul&rsquo;s Drag Race season 14, episode eight.The queens reenter the werkroom with spirits high after the ' />
<!-- End Complete Open Graph. | 0.0027949810028076s -->

<!-- Facebook Pixel Code for Business account -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '146509472638188');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=146509472638188&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->



<!-- Facebook Pixel Code for Spectrum Ad account ending in 6842 -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '331727487296842');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=331727487296842&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<script>
  fbq('track', 'ViewContent');
</script>      <style>
      img.wp-post-image{ display: none !important; }
      </style>
      
						<style type="text/css">
														body,
					button,
					input,
					select,
					textarea {
						font-size: 16px;
					}
									/* Side Sidebar  Navigation*/
					.side-menu-wrap .side-nav-wrap a,
					.side-menu-wrap .side-nav-wrap ul li ul li a,
					.side-menu-wrap .side-nav-wrap ul li ul li ul li a {
						font-size: 24px;
					}
									/* Post Entry Titles */
					.entry-title {
						font-size: 24px;
					}
									/* Blockquote
					================================================== */
					blockquote {
						font-size: 18px;
					}
								</style>
			<meta name="viewport" content="width=device-width" />
	<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://ndsuspectrum.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://ndsuspectrum.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><style type="text/css">/** Mega Menu CSS: fs **/</style>
<style id="yellow-pencil">
/*
	The following CSS generated by YellowPencil Plugin.
	https://yellowpencil.waspthemes.com
*/
#site-title a{background-blend-mode:darken;background-image:url(http://ndsuspectrum.com/wp-content/uploads/2019/01/Spectrum-Logo-New-Long.jpg);color:rgb(34, 34, 34);-webkit-background-clip:padding-box;background-clip:padding-box;min-height:197px;background-repeat:repeat-x;-webkit-background-size:cover;background-size:cover;display:none;}#site-description{display:none;}#site-branding{-webkit-background-size:contain;background-size:contain;background-repeat:no-repeat;background-attachment:local;color:rgb(112, 112, 112);-webkit-background-clip:padding-box;background-clip:padding-box;background-blend-mode:darken;background-position:50% 50%;-webkit-animation-fill-mode:both;animation-fill-mode:both;-webkit-animation-iteration-count:1;animation-iteration-count:1;margin-bottom:0px !important;background-image:url(http://ndsuspectrum.com/wp-content/uploads/2019/01/Spectrum-Logo-New.jpg) !important;padding-bottom:86px;}.top-bar-wrap .widget .execphpwidget{min-height:48px;}.top-header .main-header .header-wrap-inner{padding-left:0px;-webkit-animation-fill-mode:both;animation-fill-mode:both;padding-bottom:0px;margin-bottom:15px;}.header-social-block ul a{-webkit-animation-fill-mode:both;animation-fill-mode:both;}.header-social-block ul a.yp_hover{-webkit-animation-delay:0s;animation-delay:0s;-webkit-animation-duration:1s;animation-duration:1s;-webkit-animation-name:pop;animation-name:pop;}#secondary{padding-left:34px;}#primary-menu > .menu-item > a{color:#ecf0f1;font-weight:600;}#primary-menu{-webkit-box-shadow:none;box-shadow:none;-webkit-animation-fill-mode:both;animation-fill-mode:both;background-color:rgba(45,45,45,0.96) !important;}#site-branding.yp_click{-webkit-animation-delay:0s;animation-delay:0s;-webkit-animation-duration:1s;animation-duration:1s;-webkit-animation-name:spin;animation-name:spin;}.g-1 a img{display:inline-block;height:60px;}.hentry blockquote{border-color:#7a7a7a;color:#2b2b2b;}@media (max-width:767px){.top-header .top-bar .top-bar-wrap{visibility:visible !important;}}@media (max-width:319px){.top-header .top-bar .top-bar-wrap{position:relative;visibility:visible;}#page #masthead .header-wrap .top-header .top-bar .top-bar-wrap{width:auto !important;height:auto !important;-webkit-box-sizing:content-box !important;box-sizing:content-box !important;}}
</style></head>
<body class="post-template-default single single-post postid-111175 single-format-standard wp-embed-responsive  boxed-layout gutenberg wpb-js-composer js-comp-ver-4.11.1 vc_responsive">
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#site-content-contain">Skip to content</a>
	<!-- Masthead ============================================= -->
	<header id="masthead" class="site-header" role="banner">
		<div class="header-wrap">
			<!-- Top Header============================================= -->
			<div class="top-header">
									<div class="top-bar">
						<div class="top-bar-wrap">
							<aside id="execphp-4" class="widget widget_contact"><h3 class="widget-title">Date</h3>			<div class="execphpwidget">
Mon,  February 28, 2022 Edition
 </div>
		</aside><aside id="adrotate_widgets-27" class="widget widget_contact"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside>						</div> <!-- end .top-bar-wrap -->
					</div> <!-- end .top-bar -->
								<!-- Main Header============================================= -->
				<div class="main-header clearfix">
					<div class="header-wrap-inner">
						<div class="header-left">
														<div class="header-social-block">
									<div class="social-links clearfix">
	<ul><li id="menu-item-40923" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40923"><a href="https://www.facebook.com/ndsuspectrum/"><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-40924" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40924"><a href="https://twitter.com/ndsuspectrum?lang=en"><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-75557" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-75557"><a href="https://www.instagram.com/ndsu.spectrum/"><span class="screen-reader-text">instagram</span></a></li>
</ul>	</div><!-- end .social-links -->
								</div>
														</div> <!-- end .header-left -->
					

						<div id="site-branding" class="site-branding"><div id="site-detail"> <h2 id="site-title"> 				<a href="http://ndsuspectrum.com/" title="the Spectrum" rel="home"> the Spectrum </a>
				 </h2> <!-- end .site-title --> 					<div id="site-description"> For the Land and its People </div> <!-- end #site-description -->
			
		</div></div>
						<div class="header-right">
															<button id="search-toggle" class="header-search" type="button"></button>
										<div id="search-box" class="clearfix">
											<div class="search-x"></div>
												<form class="search-form" action="http://ndsuspectrum.com/" method="get" role="search">
			<label class="screen-reader-text">Search …</label>
		<input type="search" name="s" class="search-field" placeholder="Search …" autocomplete="off" />
		<button type="submit" class="search-submit"><i class="fa fa-search"></i></button>
</form> <!-- end .search-form -->										</div>  <!-- end #search-box -->
															</div> <!-- end .header-right -->
					</div> <!-- end .wrap -->

											<!-- Main Nav ============================================= -->
						<div id="sticky-header" class="clearfix">
							<nav id="site-navigation" class="main-navigation clearfix" role="navigation" aria-label="Main Menu">

							<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">
								<span class="line-bar"></span>
						  	</button> <!-- end .menu-toggle -->
							
								<ul id="primary-menu" class="menu nav-menu"><li id="menu-item-460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-460"><a href="http://www.ndsuspectrum.com">Home</a></li>
<li id="menu-item-4013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4013"><a href="http://ndsuspectrum.com/category/news/">News</a></li>
<li id="menu-item-107046" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-107046"><a href="http://ndsuspectrum.com/category/variety/">Variety</a>
<ul class="sub-menu">
	<li id="menu-item-107050" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107050"><a href="http://ndsuspectrum.com/category/variety/features/">Features</a></li>
	<li id="menu-item-107047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107047"><a href="http://ndsuspectrum.com/category/variety/arts-entertainment/music-ae/">Music</a></li>
	<li id="menu-item-107048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107048"><a href="http://ndsuspectrum.com/category/variety/arts-entertainment/movies/">Movies/TV</a></li>
	<li id="menu-item-107049" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107049"><a href="http://ndsuspectrum.com/category/variety/arts-entertainment/videogames/">Video Games</a></li>
</ul>
</li>
<li id="menu-item-821" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-821"><a href="http://ndsuspectrum.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-110532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110532"><a href="http://ndsuspectrum.com/category/chirstian-concerns/">Chirstian Concerns</a></li>
	<li id="menu-item-110534" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110534"><a href="http://ndsuspectrum.com/category/covid-19/">Covid-19</a></li>
	<li id="menu-item-110574" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110574"><a href="http://ndsuspectrum.com/category/democratic/">Democratic</a></li>
	<li id="menu-item-110575" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110575"><a href="http://ndsuspectrum.com/category/republican/">Republican</a></li>
	<li id="menu-item-110576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110576"><a href="http://ndsuspectrum.com/category/centrist/">Centrist</a></li>
	<li id="menu-item-110533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110533"><a href="http://ndsuspectrum.com/category/religion/">Religion</a></li>
</ul>
</li>
<li id="menu-item-824" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-824"><a href="http://ndsuspectrum.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-110358" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110358"><a href="http://ndsuspectrum.com/category/sports/baseball/">Baseball</a></li>
	<li id="menu-item-826" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-826"><a href="http://ndsuspectrum.com/category/sports/bball/">Basketball</a></li>
	<li id="menu-item-110361" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110361"><a href="http://ndsuspectrum.com/category/sports/football/">Football</a></li>
	<li id="menu-item-110357" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110357"><a href="http://ndsuspectrum.com/category/sports/golf/">Golf</a></li>
	<li id="menu-item-110360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110360"><a href="http://ndsuspectrum.com/category/sports/softball/">Softball</a></li>
	<li id="menu-item-110359" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110359"><a href="http://ndsuspectrum.com/category/sports/tf/">Track &amp; Field</a></li>
	<li id="menu-item-110356" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-110356"><a href="http://ndsuspectrum.com/category/sports/wrestling/">Wrestling</a></li>
</ul>
</li>
<li id="menu-item-75588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-75588"><a href="http://ndsuspectrum.com/hiring">Hiring</a></li>
</ul>							</nav> <!-- end #site-navigation -->
						</div> <!-- end #sticky-header -->
									</div> <!-- end .main-header -->
			</div> <!-- end .top-header -->

					</div> <!-- end .header-wrap -->
	</header> <!-- end #masthead -->
	<!-- Main Page Start ============================================= -->
	<div id="site-content-contain" class="site-content-contain">
		<div id="content" class="site-content">
					
<div class="wrap">
	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">
			<article id="post-111175" class="post-111175 post type-post status-publish format-standard has-post-thumbnail hentry category-arts-entertainment category-tv category-variety">
									<div class="entry-thumb">
						<figure class="entry-thumb-content">
							<img width="681" height="383" src="http://ndsuspectrum.com/wp-content/uploads/2022/02/RuPaul-Season-14-VH1-1.jpeg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" srcset="http://ndsuspectrum.com/wp-content/uploads/2022/02/RuPaul-Season-14-VH1-1.jpeg 681w, http://ndsuspectrum.com/wp-content/uploads/2022/02/RuPaul-Season-14-VH1-1-300x169.jpeg 300w" sizes="(max-width: 681px) 100vw, 681px" />						</figure>
					</div> <!-- end .entry-thumb -->
								 <header class="entry-header">
											<div class="entry-meta">
															<span class="cat-links">
									<ul class="post-categories">
	<li><a href="http://ndsuspectrum.com/category/variety/arts-entertainment/" rel="category tag">Arts &amp; Entertainment</a></li>
	<li><a href="http://ndsuspectrum.com/category/variety/arts-entertainment/tv/" rel="category tag">TV</a></li>
	<li><a href="http://ndsuspectrum.com/category/variety/" rel="category tag">Variety</a></li></ul>								</span> <!-- end .cat-links -->
													</div> <!-- end .entry-meta -->
										<h2 class="entry-title"> <a href="http://ndsuspectrum.com/recap-rupauls-drag-race-7/" title="Recap: RuPaul&#8217;s Drag Race"> Recap: RuPaul&#8217;s Drag Race </a> </h2> <!-- end.entry-title -->
											<div class="entry-meta">
							<span class="author vcard"><a href="http://ndsuspectrum.com/author/braydenzenker/" title="Recap: RuPaul&#8217;s Drag Race"><i class="fa fa-user-o"></i> Brayden Zenker</a></span><span class="posted-on"><a href="http://ndsuspectrum.com/recap-rupauls-drag-race-7/" title="February 28, 2022"><i class="fa fa-calendar-o"></i> February 28, 2022 </a></span>									<span class="comments">
									<a href="http://ndsuspectrum.com/recap-rupauls-drag-race-7/#respond"><i class="fa fa-comment-o"></i> No Comments</a> </span>
													</div> <!-- end .entry-meta -->
									</header><!-- end .entry-header -->
				<div class="entry-content">
					
<h2>Spilling the tea on season 14, episode eight</h2>



<div class="wp-block-image"><figure class="aligncenter size-full"><img loading="lazy" width="681" height="383" src="http://ndsuspectrum.com/wp-content/uploads/2022/02/RuPaul-Season-14-VH1-1.jpeg" alt="" class="wp-image-111177" srcset="http://ndsuspectrum.com/wp-content/uploads/2022/02/RuPaul-Season-14-VH1-1.jpeg 681w, http://ndsuspectrum.com/wp-content/uploads/2022/02/RuPaul-Season-14-VH1-1-300x169.jpeg 300w" sizes="(max-width: 681px) 100vw, 681px" /><figcaption>Photo Credit | VH1 | RuPaul&#8217;s Drag Race<br>The cast of season 14 of RuPaul&#8217;s Drag Race. </figcaption></figure></div>



<p><strong>*Warning* The following article contains spoilers for RuPaul’s Drag Race season 14, episode eight.</strong></p>



<p>The queens reenter the werkroom with spirits high after the non-elimination. This is kind of unique for Drag Race. I don’t think there has been a non-elimination episode like this so far into the season before. Usually, the two bottom queens are saved due to spectacular performances in the lipsync, instead the queens were all saved because of their spectacular performance in the maxi challenge. &nbsp;</p>



<p>Lady Camden is rightfully feeling very good after getting her first win of the season. She had an amazing performance in the maxi challenge as well as on the runway. She was able to turn every drag queen’s worst nightmare into a jaw-dropping runway moment.</p>



<p>Another queen that is feeling some joy is Daya Betty. She is thrilled to have finally broken her streak of being safe. She was not only in the top, but in the top two of the week to lipsync for the win. There were some girls that thought Daya shouldn’t have been in the top, (cough, cough, Jasmine), but I think she had a great performance.</p>



<p>I don’t normally recap the mini challenges but is week’s mini challenge was one that could not be skipped. The library is officially open; because reading is what darling, fundamental. Yes, that’s right, this week’s mini challenge is the iconic reading challenge. For those who don’t know what this type of reading is, reading is “The act of pointing out a flaw in someone else and exaggerating it.” I pulled the definition from Urban Dictionary so I could explain it in the straightest words possible.</p>



<p>My top three for the reading challenge was Lady Camden, Willow Pill and Bosco. Apparently RuPaul and I think alike because he decided that Bosco was the shadiest b*itch in the building. Along with being awarded the title, Bosco also won $2,500 courtesy of SweeTarts. RuPaul also gave a shoutout to Lady Camden for her shady performance.</p>



<p>To see the queens’ reading abilities in action follow this link, <a href="https://www.youtube.com/watch?v=NOR7KtQzs-w">https://www.youtube.com/watch?v=NOR7KtQzs-w</a> (skip to 4:10 for the reading challenge), or sashay over to the RuPaul’s Drag Race YouTube page. &nbsp;&nbsp;</p>



<p>For this week’s Maxi Challenge, the queens will be competing in the 60’s style girl groups the ShangRu-las, the Ru-nettes and the Rupremes. The girls argued back and worth about which girl group they wanted to be in but were finally able to come to a decision. The ShangRu-las will feature Daya Betty, Bosco and Willow Pill. The Ru-nettes will feature DeJa Skye, Jasmine Kennedie and Jorgeous. The Rupremes will feature Angeria Paris VanMicheals, Kerri Colby and Lady Camden.</p>



<h3>Maxi Challenge</h3>



<p>For this week’s maxi challenge the queens are responsible for writing their own original verse the lipsync track, coming up with group choreography, coming up with characterizations and performing it all on the main stage. In the words of Bosco, “This is a hell of a challenge.”</p>



<p>Watching the queens get ready for the challenge I think the group that has the most promise in the ShangRu-las. These three all worked really well together last week and in other challenges where they have worked together. They have cracked the code on how to do well in these challenges, make a lot of references, have a unique vision and make the judges laugh. I think this group is very likely going to be in the top this week.</p>



<p>After watching the actual performance, I definitely think the ShangRu-las were the best group this week. Like I said, these girls have cracked the code on how to do well in these challenges. Ru says this every season, you don’t need to reinvent the wheel, the wheel in just fine. These girls are doing just that. They brought a unique perspective to the song, showing their personality and chucked the song with funny material. I was locked in on the lyrics because I wanted to know what they were going to say next.</p>



<p>The weakest group for me this week was the Ru-nettes. The main culprit in my mind that both this group in the bottom for me this week was Jasmine Kennedie. Jasmine came into this competition saying she was a dancing queen. But in this challenge the choreography didn’t look natural, and you saw it on her face that she was thinking about the steps. The lack of face from Jasmine really took her out of the performance. Also, I know not everyone is a singer, but Jasmine is a terrible singer. DeJa and Jorgeous’s performances were much better in comparison across the board, but you’re only as strong as your weakest link.</p>



<p>The Rupremes, for me, were the obvious middle group of the week. That is not to say this group didn’t have its problems, they were just less obvious than the Ru-nettes. Angeria was the clear star of this group, however. Before the challenge she said that she does Diana Ross in her act, and it showed in the challenge. Kerri and Lady Camden had okay performances, but they lack the ease that Angeria did. They caused them to feel out of place next to Angeria and took a hit to the quality of their performance.</p>



<p>To see the queens’ 60’s inspired girls group performances, follow this link <a href="https://www.youtube.com/watch?v=1eOeTMPmQkA">https://www.youtube.com/watch?v=1eOeTMPmQkA</a> or sashay on over to the RuPaul’s Drag Race YouTube page.</p>



<h3>Category is…</h3>



<p>On the runway this week category is… Heart On. This week’s runway was really kind-of a letdown for me. So far, the queens have been bringing great runway looks this season. But this week I only have two words, missed opportunity. I was expecting just a lot more from this runway overall.</p>



<p>My top three looks this week were Daya Betty, Bosco and Jorgeous. These looks were my favorite of the night, but my critique for all the looks is safe. For a category like Heart On, I was expecting these girls to be DRIPPING in hearts. Some of these looks only had one heart on them. I just think that overall, the queens could have pushed these looks a lot further. Some of these girls have been bringing jaw dropping looks to this runway and they really let me down this week.</p>



<p>My bottom three looks of the night were Willow Pill, Jasmine Kennedie and Angeria. Willow’s outfit this week was just straight ugly, I’m going to say it. That was the worst thing she has worn on the runway this season and is probably in the top five worst looks of Drag Race. Both Jasmine and Angeria’s looks were just so basic. Jasmine’s look had two hearts on it and Angeria’s only had one. Had I not known what the runway category was I never would have thought it had anything to do with hearts just looking at their outfits.</p>



<p>To see all of the queens’ Heart On looks, follow this link <a href="https://twitter.com/RuPaulsDragRace/status/1497396498631311365">https://twitter.com/RuPaulsDragRace/status/1497396498631311365</a> or sashay over to the RuPaul’s Drag Race Twitter page.</p>



<h3>Tops and Bottoms</h3>



<p>The queens in the top this week are Daya Betty, DeJa Skye and Angeria Paris VanMicheals. I think these queens were definitely the standouts in their groups this week. Daya had the best characterization in her group and held character the entire performance, even when the ShandRu-las weren’t the focus. I think DeJa was the backbone of the Ru-nettes and overwhelmingly gave the best performance of that group. Same with Angeria, I think the Rupremes performed better overall but Angeria’s performance was the gold standard that the other two queens should have been reaching for.</p>



<p>The queens in the bottom this week are Jasmine Kennedie, Lady Camden and Kerri Colby. I do agree with this bottom three, it is just hard to see them here. Kerri and Lady Camden have been two of my favorite queens since the beginning and Jasmine just has an amazing week last week in the soap opera challenge. However, Jasmine’s performance was off on multiple levels: dancing, singing and characterization. It was really hard to watch her performance this week. Kerri and Lady Camden were on two different spectrums in this challenge. For Kerri the performance felt almost forced and was relying on extreme body language too much. Lady Camden, on the other hand, was really reserved and seemed to fade into the background.</p>



<p>After deliberating with the judges, RuPaul gives this week’s win to Daya Betty. After finally breaking her safe streak last week she finally got her first win, and a $5,000 cash tip courtesy of Snag Tights. Daya has really pushed through these last few weeks and has proven she is competition for the other girls.</p>



<p>The two queens lipsycing for their lives this week are Jasmine Kennedie and Kerri Colby. I know that Jasmine and Kerri have gotten very close during the competition and Kerri had helped Jasmine feel comfortable telling the other queens that she is a trans woman. This will definitely be an emotional lipsync for both of them.</p>



<p>This week’s lipsync song is &#8220;Un-Break My Heart&#8221; by Toni Braxton, the Hex Hector Remix. Both Jasmine and Kerri gave great lipsyncs. They both gave extremely emotional performances. However, as a dancing queen Jasmine has just a few more tricks up her sleeve. A well-timed split from Jasmine is what I think sealed Kerri’s fate.</p>



<p>In the end RuPaul does decide to keep Jasmine over Kerri. I, and Jasmine, was devastated that Kerri could possibly be going home. Our only hope left was that Kerri had the golden chocolate bar. Unfortunately, Kerri’s bar is just chocolate, meaning that her time on season 14 has officially come to a close.</p>



<p>To see Jasmine and Kerri’s lipsync, follow this link <a href="https://www.youtube.com/watch?v=QR-X49njac0">https://www.youtube.com/watch?v=QR-X49njac0</a> or sashay over to the RuPaul’s Drag Race YouTube page.</p>
<div class="tptn_counter" id="tptn_counter_111175"><script type="text/javascript" data-cfasync="false" src="http://ndsuspectrum.com/?top_ten_id=111175&amp;view_counter=1&amp;_wpnonce=d4bfa2aa93"></script></div>			
				</div><!-- end .entry-content -->
				
<div id="comments" class="comments-area">
				<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/recap-rupauls-drag-race-7/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="http://ndsuspectrum.com/wp-login.php?redirect_to=http%3A%2F%2Fndsuspectrum.com%2Frecap-rupauls-drag-race-7%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	</div> <!-- .comments-area -->			</article><!-- end .post -->
			
	<nav class="navigation post-navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://ndsuspectrum.com/ndsu-2/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">How you choose a college</span></a></div></div>
	</nav>		</main><!-- end #main -->
	</div> <!-- end #primary -->
	
<aside id="secondary" class="widget-area" role="complementary">
    <aside id="adrotate_widgets-22" class="widget adrotate_widgets"><div class="g g-2"><div class="g-dyn a-97 c-1"><a class="gofollow" data-track="OTcsMiwxLDYw" href=" https://uptowncheapskate.com/location/fargo/ "><img src="http://ndsuspectrum.com/wp-content/uploads/2022/01/BRANDS-YOU-LOVE-FOR-LESS-Digital-Ad_300x250-UC-Q3.2021.jpg" /></a></div></div></aside><aside id="adrotate_widgets-23" class="widget adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside><aside id="adrotate_widgets-24" class="widget adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside>
		<aside id="recent-posts-7" class="widget widget_recent_entries">
		<h2 class="widget-title">Recent Posts</h2>
		<ul>
											<li>
					<a href="http://ndsuspectrum.com/politics-3/">Judge Jackson</a>
											<span class="post-date">February 28, 2022</span>
									</li>
											<li>
					<a href="http://ndsuspectrum.com/track-field-teams-finish-2nd-3rd-at-summit-championships/">Track &#038; field teams finish 2nd &#038; 3rd at Summit Championships</a>
											<span class="post-date">February 28, 2022</span>
									</li>
											<li>
					<a href="http://ndsuspectrum.com/recap-rupauls-drag-race-7/" aria-current="page">Recap: RuPaul&#8217;s Drag Race</a>
											<span class="post-date">February 28, 2022</span>
									</li>
											<li>
					<a href="http://ndsuspectrum.com/ndsu-2/">How you choose a college</a>
											<span class="post-date">February 25, 2022</span>
									</li>
											<li>
					<a href="http://ndsuspectrum.com/capitalism-threatens-black-history-month/">Capitalism threatens Black History Month</a>
											<span class="post-date">February 25, 2022</span>
									</li>
					</ul>

		</aside></aside><!-- end #secondary -->
</div><!-- end .wrap -->
</div><!-- end #content -->
		<!-- Footer Start ============================================= -->
		<footer id="colophon" class="site-footer" role="contentinfo">
				<div class="widget-wrap">
			<div class="wrap">
				<div class="widget-area">
					<div class="column-4"><aside id="meta-8" class="widget widget_meta"><h3 class="widget-title">Meta</h3>
		<ul>
						<li><a rel="nofollow" href="http://ndsuspectrum.com/wp-login.php">Log in</a></li>
			<li><a href="http://ndsuspectrum.com/feed/">Entries feed</a></li>
			<li><a href="http://ndsuspectrum.com/comments/feed/">Comments feed</a></li>

			<li><a href="https://wordpress.org/">WordPress.org</a></li>
		</ul>

		</aside></div><!-- end .column4  --><div class="column-4"><aside id="text-4" class="widget widget_text"><h3 class="widget-title">Advertise</h3>			<div class="textwidget"><p><a href="http://ndsuspectrum.com/advertise/">Advertise with us!</a></p>
<p><a href="http://ndsuspectrum.com/place-a-classified/">Place a Classified</a></p>
<p><a href="http://ndsuspectrum.com/place-a-display-ad/">Place a Display</a></p>
</div>
		</aside></div><!--end .column4  --><div class="column-4"><aside id="text-6" class="widget widget_text"><h3 class="widget-title">Contact</h3>			<div class="textwidget"><p><a href="http://ndsuspectrum.com/about">About</a></p>
<p><a href="http://ndsuspectrum.com/staff">Staff</a></p>
<p><a href="http://ndsuspectrum.com/contact/">Contact us!</a></p>
<p>&nbsp;</p>
</div>
		</aside></div><!--end .column4  --><div class="column-4"><aside id="text-7" class="widget widget_text"><h3 class="widget-title">More</h3>			<div class="textwidget"><p><a href="http://ndsuspectrum.com/latest-issue/">Latest Issue</a></p>
<p><a href="http://ndsuspectrum.com/classifieds">Classifieds</a></p>
</div>
		</aside></div><!--end .column4-->				</div> <!-- end .widget-area -->
			</div> <!-- end .wrap -->
		</div> <!-- end .widget-wrap -->
	
			<!-- Site Information ============================================= -->
			<div class="site-info"  >
				<div class="wrap">
						<div class="social-links clearfix">
	<ul><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40923"><a href="https://www.facebook.com/ndsuspectrum/"><span class="screen-reader-text">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-40924"><a href="https://twitter.com/ndsuspectrum?lang=en"><span class="screen-reader-text">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-75557"><a href="https://www.instagram.com/ndsu.spectrum/"><span class="screen-reader-text">instagram</span></a></li>
</ul>	</div><!-- end .social-links -->
						<div class="copyright">
					<div id="text-9" class="copyright widget_text">			<div class="textwidget"><p>@ NDSU SPECTRUM 2019</p>
</div>
		</div><div id="search-2" class="copyright widget_search"><form class="search-form" action="http://ndsuspectrum.com/" method="get" role="search">
			<label class="screen-reader-text">Search …</label>
		<input type="search" name="s" class="search-field" placeholder="Search …" autocomplete="off" />
		<button type="submit" class="search-submit"><i class="fa fa-search"></i></button>
</form> <!-- end .search-form --></div><div id="adrotate_widgets-18" class="copyright adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></div><div id="adrotate_widgets-5" class="copyright adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></div><div id="ritsocialwidget-3" class="copyright RITSocialWidget"><div class="eva-social-icon clearfix"><a href="http://www.facebook.com//ndsuspectrum" target="_blank" title="ion-social-facebook" class="ion-social-facebook"><i class="fa fa-facebook"></i></a><a href="http://twitter.com//NDSUSpectrum" target="_blank" title="ion-social-twitter" class="ion-social-twitter"><i class="fa fa-twitter"></i></a><a href="http://instagram.com/thespectrumndsu" target="_blank" title="ion-social-instagram" class="ion-social-instagram"><i class="fa fa-instagram"></i></a></div></div><div id="widget_tptn_pop-5" class="copyright tptn_posts_list_widget"><h2 class="widgettitle">Most Popular Posts</h2>
<div class="tptn_posts  tptn_posts_widget tptn_posts_widget5"><ul><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/luna-fargo-best-restaurant-in-fargo/"     class="tptn_link"><span class="tptn_title">Luna Fargo: Best restaurant in Fargo</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/braydenzenker/">Brayden Zenker</a></span> <span class="tptn_date"> February 9, 2022</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/fargo/"     class="tptn_link"><span class="tptn_title">Reasons I don&#8217;t like Fargo</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/abigailfaulkner/">Abigail Faulkner</a></span> <span class="tptn_date"> February 22, 2022</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/trauma-is-the-watchword/"     class="tptn_link"><span class="tptn_title">Trauma is the watchword</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/delaneyhalloran/">Delaney Halloran</a></span> <span class="tptn_date"> February 16, 2022</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/death-to-capitalist-sanctioned-love-making/"     class="tptn_link"><span class="tptn_title">Death to capitalist-sanctioned love-making</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/delaneyhalloran/">Delaney Halloran</a></span> <span class="tptn_date"> February 8, 2022</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/the-moral-obligation-not-to-have-kids/"     class="tptn_link"><span class="tptn_title">The moral obligation not to have kids</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/delaneyhalloran/">Delaney Halloran</a></span> <span class="tptn_date"> February 23, 2022</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/valentines-day-events-in-fargo-moorhead-area/"     class="tptn_link"><span class="tptn_title">Valentine&#8217;s Day events in Fargo/Moorhead area</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/annekesler/">Anne Kesler</a></span> <span class="tptn_date"> February 9, 2022</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/ndsu/"     class="tptn_link"><span class="tptn_title">Parking on campus is preposterous</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/abigailfaulkner/">Abigail Faulkner</a></span> <span class="tptn_date"> February 15, 2022</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/jobs-that-pay-you-to-go-to-school/"     class="tptn_link"><span class="tptn_title">Jobs that pay you to go to school</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/annekesler/">Anne Kesler</a></span> <span class="tptn_date"> February 3, 2022</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/religion/"     class="tptn_link"><span class="tptn_title">Modern Atheistic Religions</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/azalea-benjamin/">Azalea Benjamin</a></span> <span class="tptn_date"> February 7, 2022</span> </span></li><li><span class="tptn_after_thumb"><a href="http://ndsuspectrum.com/hope-blooms-in-the-community/"     class="tptn_link"><span class="tptn_title">Hope Blooms in the community</span></a><span class="crp_author">  by <a href="http://ndsuspectrum.com/author/alissaknudson/">Alissa Knudson</a></span> <span class="tptn_date"> February 10, 2022</span> </span></li></ul><div class="tptn_clear"></div></div></div>					</div><!-- end .copyright -->
					<div style="clear:both;"></div>
				</div> <!-- end .wrap -->
			</div> <!-- end .site-info -->
								<button class="go-to-top" type="button">
						<span class="screen-reader-text">Go to top</span>
						<span class="icon-bg"></span>
							 <span class="back-to-top-text">Top</span>
							<i class="fa fa-angle-up back-to-top-icon"></i>
					</button>
						<div class="page-overlay"></div>
		</footer> <!-- end #colophon -->
	</div><!-- end .site-content-contain -->
</div><!-- end #page -->
<script type='text/javascript' id='jshowoff-adrotate-js-extra'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"http:\/\/ndsuspectrum.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js' id='jshowoff-adrotate-js'></script>
<script type='text/javascript' id='clicktrack-adrotate-js-extra'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/ndsuspectrum.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js' id='clicktrack-adrotate-js'></script>
<script type='text/javascript' src='//www.google.com/recaptcha/api.js?ver=7.8.5&#038;onload=ccfRecaptchaOnload&#038;render=explicit' id='ccf-google-recaptcha-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/rit-core/assets/js/masonry.pkgd.min.js?ver=2.0' id='rit-masonry-js-js'></script>
<script type='text/javascript' id='tptn_tracker-js-extra'>
/* <![CDATA[ */
var ajax_tptn_tracker = {"ajax_url":"http:\/\/ndsuspectrum.com\/wp-admin\/admin-ajax.php","top_ten_id":"111175","top_ten_blog_id":"1","activate_counter":"11","top_ten_debug":"0","tptn_rnd":"1172696399"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/top-10/includes/js/top-10-tracker.min.js?ver=1.0' id='tptn_tracker-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/comment-reply.min.js?ver=5.9.1' id='comment-reply-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/backbone.min.js?ver=1.4.0' id='backbone-js'></script>
<script type='text/javascript' id='wp-api-ccf-js-extra'>
/* <![CDATA[ */
var WP_API_Settings = {"root":"http:\/\/ndsuspectrum.com\/wp-json\/","nonce":"e328ede17b"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/custom-contact-forms/wp-api/wp-api.js?ver=1.2' id='wp-api-ccf-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/themes/cocktail/js/cocktail-main.js?ver=5.9.1' id='cocktail-main-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/themes/cocktail/assets/sticky/jquery.sticky.min.js?ver=5.9.1' id='jquery-sticky-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/themes/cocktail/assets/sticky/sticky-settings.js?ver=5.9.1' id='cocktail-sticky-settings-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/themes/cocktail/js/navigation.js?ver=5.9.1' id='cocktail-navigation-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/themes/cocktail/js/skip-link-focus-fix.js?ver=5.9.1' id='cocktail-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-includes/js/hoverIntent.min.js?ver=1.10.2' id='hoverIntent-js'></script>
<script type='text/javascript' id='megamenu-js-extra'>
/* <![CDATA[ */
var megamenu = {"timeout":"300","interval":"100"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ndsuspectrum.com/wp-content/plugins/megamenu/js/maxmegamenu.js?ver=2.9.5' id='megamenu-js'></script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({ groupid: 1, speed: 6000 });
	jQuery('.g-2').gslider({ groupid: 2, speed: 6000 });
	jQuery('.g-4').gslider({ groupid: 4, speed: 6000 });
	jQuery('.g-5').gslider({ groupid: 5, speed: 6000 });
}
});
</script>
<!-- /AdRotate JS -->

</body>
</html>